Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#10846 closed defect (fixed)

[regression] TabContainer: menu click selects tab but doesn't update content

Reported by: waliays Owned by: bill
Priority: high Milestone: 1.4.3
Component: Dijit Version: 1.4.2
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

version 1.4.2 example attached

dijit.layout.TabContainer with more tabs than visible at one time shows a select-tab-dropdown, selecting a tab highlights the correct tab's handle and scrolls it into the visible area but the content of the tab stays the beforehand seleted tab's one;

a click on the already selected tab's handle updates the content; can certainly be done with an event handler, but I think that behaviour is not intended;

tested with Firefox 3.5.8 and Konqueror 4.3.2 on Linux

Attachments (1)

x4.html (1.3 KB) - added by waliays 10 years ago.
demo html

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by waliays

Attachment: x4.html added

demo html

comment:1 Changed 10 years ago by bill

Milestone: tbd1.5
Owner: set to bill
Status: newassigned
Summary: tab selector selects tab but doesn't update content[regression] tab selector selects tab but doesn't update content
Version: 1.4.01.4.2

Ugh, looks like a regression between 1.4.1 and 1.4.2, probably from #10727.

It happens in test_TabContainer.html.

Thanks for the heads up.

comment:2 Changed 10 years ago by bill

Description: modified (diff)
Summary: [regression] tab selector selects tab but doesn't update content[regression] TabContainer: menu click selects tab but doesn't update content

Yes, it's from #10727, rev [21355]. Maybe we should have a 1.4.3 release to fix this. Anyway, I'll check in a fix to the 1.4/ branch and to trunk.

comment:3 Changed 10 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [21592]) Fix problem after [21355] where selecting a tab from the menu wouldn't actually select a tab. Fixes #10846, refs #10727 !strict.

comment:4 Changed 10 years ago by Adam Peller

Milestone: 1.51.4.3
Note: See TracTickets for help on using tickets.