Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#10821 closed defect (fixed)

Tooltip on MenuItem does not hide when MenuItem is clicked

Reported by: Manuel Irrschik Owned by: bill
Priority: high Milestone: 1.7
Component: Dijit Version: 1.4.0
Keywords: tooltip, menu, menuitem Cc: ben hockey
Blocked By: Blocking:

Description

i ran across a problem with tooltips on menu-items:

the tooltip is displayed properly for each menu item, but when i click on one of the menu items, the corresponding tooltip is not hidden.

i made a small testcase (attached) which shows exactly the same behaviour (tested on FF 3.5.8 Linux/Windows?)

Attachments (1)

menuTest.html (1.1 KB) - added by Manuel Irrschik 10 years ago.
Testcase

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by Manuel Irrschik

Attachment: menuTest.html added

Testcase

comment:1 Changed 10 years ago by bill

Milestone: tbd1.6
Owner: set to bill

Thanks for the report. I've seen this before with hover effects for MenuItem's, the problem is that there's no onmouseout event on the menu item because the whole menu disappears before the mouse is moved off of it. Not sure how to fix it but I'll look at it.

comment:2 Changed 10 years ago by Manuel Irrschik

i just had a look at the Tooltip internals and what events are being fired

the tooltip is not just hidden at the _onTargetMouseLeave, but also at the _onTargetBlur event - shouldn't there be a blur event when the menu (and so the menu items) are hidden? (maybe fire it manually in the menu code or so... - just an idea)

comment:3 Changed 10 years ago by bill

Agreed, there should be a blur event (but there isn't). Maybe I can fire it manually after #9692 is checked in.

comment:4 Changed 9 years ago by ben hockey

Cc: ben hockey added

i'm seeing a similar behavior with the tooltips for 'validation' inputs in a dialog.

comment:5 Changed 9 years ago by ben hockey

see #11143

comment:6 Changed 9 years ago by bill

Milestone: 1.6future

comment:7 Changed 8 years ago by bill

Milestone: future1.7
Resolution: fixed
Status: newclosed

Turns out this was already fixed by [25493].

comment:8 Changed 8 years ago by bill

(In [25501]) Test that tooltip on MenuItem is hidden when menu is closed, refs #10821.

Note: See TracTickets for help on using tickets.