Opened 10 years ago

Closed 10 years ago

#10793 closed defect (fixed)

[patch][cla]typematic typo

Reported by: youngho Owned by: Douglas Hays
Priority: high Milestone: 1.5
Component: Dijit Version: 1.4.0
Keywords: Cc:
Blocked By: Blocking:

Description

I found a typo in the addKeyListener.

the document said that the first parm of the trigger method should be event but in the addKeyListener it passed keyObject.

Now I can get key event in the callback function after patch.

Attachments (1)

typematic.patch (701 bytes) - added by youngho 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by youngho

Attachment: typematic.patch added

comment:1 Changed 10 years ago by bill

Owner: set to Douglas Hays

Not sure I follow, it seems like evt and keyObj are the same at that point.

comment:2 Changed 10 years ago by Douglas Hays

Milestone: tbd1.5
Status: newassigned

comment:3 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

(In [21454]) Fixes #10793. Send the real keypress event to trigger instead of the very sparse but similar keyCode object so that the user can access target and other event attributes. Subsequent timed callbacks will receive an event object copy with faux:true to mimic the dojo event subsystem and to eliminate problems caused by event object tweaking by the browser after the real event handler has finished processing.

Note: See TracTickets for help on using tickets.