Opened 10 years ago

Closed 10 years ago

#10780 closed defect (fixed)

TitlePane - not valid xhtml, needs img tag closing

Reported by: Inarus Owned by: bill
Priority: high Milestone: 1.5
Component: Dijit Version: 1.4.0
Keywords: TitlePane xhtml img closing tag Cc:
Blocked By: Blocking:

Description (last modified by bill)

This needs changing as it breaks when displaying in application/xml+xhtml. Also occurs in 1.4.1 but that is no option for that in the select box.

This is my first bug report, so I don't know how to put in code, so I hope this is ok.

In dijit/TitlePane.js, line 14 col 647

waiRole=\"presentation\"\n\t\t><span dojoAttachPoint=\"arrowNodeInner\"

should be changed with

waiRole=\"presentation\" />\n\t\t<span dojoAttachPoint=\"arrowNodeInner\"

Note that in TitlePane.js it breaks line in a weird place. While not a bug, I've added that to the fix above, of course the most important thing is that the closing / is added to the img tag.

Change History (5)

comment:1 Changed 10 years ago by bill

Component: GeneralDijit
Description: modified (diff)
Milestone: tbd1.5
Owner: changed from anonymous to bill
Status: newassigned

Thanks for the heads-up, looks like a bunch of widgets are missing that /, although some have it. I'll fix.

About the spacing, that's intentional because on some browsers

<img><span>...

renders differently than

<img> <span>

(the latter has more space between the image and the text than the former).

comment:2 Changed 10 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [21414]) Use <img/> not <img> so that templates work in XHTML documents too. Seems to work in quirks mode (tested on IE6), and some of our templates already have <img/>, so it seems safe. Fixes #10759, #10780.

comment:3 Changed 10 years ago by bill

(In [21424]) Use <img/> not <img> so that templates work in XHTML documents too. Refs #10759, #10780.

comment:4 in reply to:  2 Changed 10 years ago by davidmark

Resolution: fixed
Status: closedreopened

Replying to bill:

(In [21414]) Use <img/> not <img> so that templates work in XHTML documents too. Seems to work in quirks mode (tested on IE6), and some of our templates already have <img/>, so it seems safe. Fixes #10759, #10780.

IE doesn't support XHTML at all. It just throws out the slashes as HTML errors. And Dojo doesn't work with _real_ XHTML either, so adding slashes to turn what _must_ be served as HTML into invalid HTML makes little sense. Test results in IE are clearly meaningless as well.

comment:5 Changed 10 years ago by bill

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.