Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#10743 closed defect (fixed)

[regression] ComboButton: no label in RTL mode (IE/quirks)

Reported by: bill Owned by: Douglas Hays
Priority: high Milestone: 1.4.2
Component: Dijit - Form Version: 1.4.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

From themeTesterQuirk.html?dir=rtl on IE8:

screenshot

Happens also on IE8 in IE7 compat mode, but not FF3.6, so I guess it's limited to IE/quirks.

Attachments (1)

buttons.png (9.1 KB) - added by bill 9 years ago.
screenshot

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by bill

Attachment: buttons.png added

screenshot

comment:1 Changed 9 years ago by bill

Description: modified (diff)
Summary: ComboButton: no label in RTL mode (IE8/quirks)ComboButton: no label in RTL mode (IE/quirks)

comment:2 Changed 9 years ago by bill

Summary: ComboButton: no label in RTL mode (IE/quirks)[regression] ComboButton: no label in RTL mode (IE/quirks)

Working in 1.3, broken in 1.4.

comment:3 Changed 9 years ago by bill

Milestone: tbd1.4.2
Owner: set to Douglas Hays

Doug, can you take a look? It broke in [17678] with the introduction of the <button> tag into the ComboButton template. The inline <div>'s inside of the <button> are getting offset, positioned to the left of the <button>, apparently due to a browser bug.

comment:4 Changed 9 years ago by Douglas Hays

There's something non-obvious going on:
tests/quirks.html?file=form/test_button.html&dir=rtl
works just fine.

comment:5 Changed 9 years ago by Douglas Hays

(In [21353]) References #10743. Add IE/quirks/rtl specific CSS rule to workaround browser bug when rendering BUTTON tags inside TABLE inside DIV that is display:none initially.

comment:6 Changed 9 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [21354]) Fixes #10743. Add IE/quirks/rtl specific CSS rule to workaround browser bug when rendering BUTTON tags inside TABLE inside DIV that is display:none initially.

comment:7 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.