Opened 10 years ago

Closed 10 years ago

#10742 closed defect (fixed)

[regression] TabContainer: RTL mode tab labels don't show up (webkit, IE quirks)

Reported by: bill Owned by: bill
Priority: high Milestone: 1.4.2
Component: Dijit Version: 1.4.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

As Dustin mentioned in #10676, the tab labels in themeTester.html?dir=rtl don't show up on safari (or chrome). Also failing on IE8 in quirks mode. They work on FF.

Problem started in 1.4 (presumably because of the scrolling tabs feature), and occurs in themeTester.

Also occurs in test_TabContainer.html, but only when you try to scroll the tabs left/right.

Change History (2)

comment:1 Changed 10 years ago by bill

Description: modified (diff)
Summary: [regression] TabContainer: RTL mode tab labels don't show up (webkit)[regression] TabContainer: RTL mode tab labels don't show up (webkit, IE quirks)

comment:2 Changed 10 years ago by bill

Resolution: fixed
Status: newclosed

(In [21344]) Making scrolling tabs work in RTL mode on webkit (see themeTester.html?dir=rtl) and IE8/quirks mode (see themeTesterQuirk.html?dir=rtl).

Webkit has the same scrollLeft meaning (in RTL mode) as IE6/7. Wonder if webkit will change to match the spec in the future.

Fixes #10742, refs #9004 !strict

Note: See TracTickets for help on using tickets.