Opened 10 years ago

Closed 9 years ago

#10739 closed defect (invalid)

Keyboard events and multiple dialogs

Reported by: dylan Owned by: bill
Priority: high Milestone: tbd
Component: Dijit Version: 1.4.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

The Dijit dialog has issues with keyboard events when multiple dialogs are open. Would this patch solve this issue? Imagine typing tab keys for controls inside a dialog, etc.

(issue identified by Lu Wei of Huawei)

Index: Dialog.js
===================================================================
--- Dialog.js   (revision 21342)
+++ Dialog.js   (working copy)
@@ -422,7 +422,7 @@
                                        this._oldViewport = viewport;
                                }
                        }));
-                       this._modalconnects.push(dojo.connect(dojo.doc.documentElement, "onkeypress", this, "_onKey"));
+                       this._modalconnects.push(dojo.connect(this.domNode, "onkeypress", this, "_onKey"));
 
                        dojo.style(this.domNode, {
                                opacity:0,

Change History (2)

comment:1 Changed 9 years ago by bill

Description: modified (diff)

Can you be specific about what the problem is? I guess you are saying that two dialogs react to the same keystroke, but what happens exactly?

comment:2 Changed 9 years ago by bill

Resolution: invalid
Status: newclosed

Closing for lack of test case, please reopen with test case and specific description of problem.

Note: See TracTickets for help on using tickets.