Opened 10 years ago

Closed 10 years ago

#10736 closed defect (fixed)

Plot's shadows attribute does not work with dojox.charting.widget.Chart2D

Reported by: Jared Jurkiewicz Owned by: Eugene Lazutkin
Priority: high Milestone: 1.5
Component: Charting Version: 1.4.0
Keywords: Cc:
Blocked By: Blocking:

Description

"shadows" attribute specified to "plot" for Chart2D markup does not work:

<div dojoType="dojox.charting.widget.Chart2D" id="myChart" style="width: 200px; height: 200px;">

<div class="plot" name="default" type="Lines" tension="3" shadows="{dx: 2, dy: 2, dw: 2}"></div>

This is caused by a simple bug in dojox.charting.plot2d.Default. The value of "shadows" parameter in "defaultParams" is defined as 0:

shadows: 0, draw shadows

which must be null, so that "shadows" attribute is parsed as "object".

shadows: null, draw shadows

Change History (2)

comment:1 Changed 10 years ago by Eugene Lazutkin

Milestone: tbd1.5
Priority: normalhigh
Status: newassigned

comment:2 Changed 10 years ago by Eugene Lazutkin

Resolution: fixed
Status: assignedclosed

(In [21710]) Right default for shadows, thx jaredj, !strict, fixes #10736.

Note: See TracTickets for help on using tickets.