Opened 9 years ago

Closed 6 years ago

#10718 closed defect (fixed)

TimeTextBox-popup shivers, when mousepointer stays between to entries

Reported by: dafoo Owned by: bill
Priority: high Milestone: 1.9
Component: Dijit - Form Version: 1.4.0
Keywords: Cc:
Blocked By: Blocking:

Description

To reproduce this bug, open Firefox and visit http://docs.dojocampus.org/dijit/form/TimeTextBox, open the second example, open the TimeTextBox?-popup by clicking inside the Timebox, move the mousecursor between 14:45 and 15:00.

Attachments (1)

10718.patch (1.4 KB) - added by Douglas Hays 9 years ago.
possible fix to tundra

Download all attachments as: .zip

Change History (16)

comment:1 Changed 9 years ago by bill

Owner: set to Douglas Hays

Doug, I think you fixed this already? I can reproduce it on FF on the dojo campus sight but not on trunk, in test_TimeTextBox.html.

comment:2 Changed 9 years ago by Douglas Hays

Resolution: worksforme
Status: newclosed

I'm not seeing this with the new website using any of the CDNs or trunk:
http://www.dojotoolkit.org/reference-guide/dijit/form/TimeTextBox.html#dijit-form-timetextbox
If anyone can recreate it using the above URL, then please indicate browser version/OS/and build selected.

comment:3 in reply to:  2 Changed 9 years ago by dafoo

Replying to doughays:

I'm not seeing this with the new website using any of the CDNs or trunk:
http://www.dojotoolkit.org/reference-guide/dijit/form/TimeTextBox.html#dijit-form-timetextbox
If anyone can recreate it using the above URL, then please indicate browser version/OS/and build selected.

Thank you for sharing.

I can recreate it with:

OS: Mac OS X 10.5.8 Browser: Firefox 3.5.8 build: Declarative example

comment:4 Changed 9 years ago by dafoo

Resolution: worksforme
Status: closedreopened

Just for curiosity: Will this be fixed? Thank you in advance.

comment:5 Changed 9 years ago by Douglas Hays

Milestone: tbdfuture
severity: normalminor

This is a minor issue that I can recreate on a Mac but not on Windows. The mouse has to be placed over a thin line and moving it 1px in either vertical direction fixes the problem. I'm deferring this unless someone can submit a patch.

comment:6 Changed 9 years ago by bill

So, we saw this on claro too and I think it's fixed in claro. The issue is that (on tundra) the TimePicker? items change font settings on hover (to bold, IIRC). Trying to predict the pixel difference between two fonts is a losing battle because (as you sort-of mentioned) the font behavior depends on the OS.

So we could copy the claro CSS over to tundra, or mark this as fixed because it works in claro (or wontfix, depending on your philosophical outlook).

comment:7 Changed 9 years ago by Douglas Hays

I'm unable to recreate this usng test_TimeTextBox.html or themeTester.html using the tundra theme which makes this difficult to debug and fix, and an even lower priority.

comment:8 Changed 9 years ago by Douglas Hays

Resolution: wontfix
Status: reopenedclosed

Marking this wontfix until a standalone testcase that demonstrates the problem can be attached

comment:9 in reply to:  6 Changed 9 years ago by dafoo

Replying to bill:

So, we saw this on claro too and I think it's fixed in claro. The issue is that (on tundra) the TimePicker? items change font settings on hover (to bold, IIRC). Trying to predict the pixel difference between two fonts is a losing battle because (as you sort-of mentioned) the font behavior depends on the OS.

So we could copy the claro CSS over to tundra, or mark this as fixed because it works in claro (or wontfix, depending on your philosophical outlook).

Here we go. For me this fixed the problem:

trundra.css original:

.tundra .dijitTimePickerMarkerHover {
	border-top: 1px solid #ccc;
}
.tundra .dijitTimePickerTickHover,
.tundra .dijitTimePickerTickSelected {
	margin-top:-0.3em;
	margin-bottom:-0.3em;
	border-bottom: none;
}

tundra.css new:

.tundra .dijitTimePickerMarkerHover {

}
.tundra .dijitTimePickerTickHover,
.tundra .dijitTimePickerTickSelected {

}

Changed 9 years ago by Douglas Hays

Attachment: 10718.patch added

possible fix to tundra

comment:10 Changed 9 years ago by Douglas Hays

Thanks dafoo. I attached a patch that goes in a different direction and overhauls tundra's timepicker CSS so there's almost no height jittering at all when you're moving the mouse over the menu which really annoys me when usng tundra. I'd like comments.

comment:11 Changed 9 years ago by Douglas Hays

Resolution: wontfix
Status: closedreopened

comment:12 Changed 8 years ago by bill

Component: DijitDijit - Form

comment:13 Changed 6 years ago by bill

In [31153]:

Don't change border on hovering item in TimePicker drop down; it changes the width of the dropdown and on Chrome/win gives the dropdown a horizontal scrollbar. Refs #7631, #10718.

comment:14 Changed 6 years ago by bill

Milestone: future1.9
Owner: changed from Douglas Hays to bill
Status: reopenedassigned

[31153] was for claro. But given my changes in #7631 the TimePicker CSS for the deprecated themes (tundra, nihilo, soria) needs more work too. I'm going to simplify the CSS considerably (even more than Doug's patch) and check in changes.

comment:15 Changed 6 years ago by bill

Resolution: fixed
Status: assignedclosed

In [31154]:

Simplify CSS for tundra, nihilo, soria, and nihilo TimePicker. In particular, don't change border/font/etc. on hovering items since it jiggles around the rest of the items. Refs #7631, and fixes #10718.

Note: See TracTickets for help on using tickets.