Opened 9 years ago

Closed 7 years ago

#10700 closed defect (worksforme)

dojo.moduleUrl bug

Reported by: ben hockey Owned by: ben hockey
Priority: low Milestone: future
Component: Loader Version: 1.4.0
Keywords: Cc:
Blocked By: Blocking:

Description

dojo.moduleUrl is giving the wrong output for custom module paths

dojo.registerModulePath('foo', '../../foo');
console.log(dojo.moduleUrl('foo').toString());
console.log(dojo.moduleUrl('foo', 'bar').toString());

try the above using the firebug console at http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_Button.html and the output will be

../../../dojo/../../foo/
../../../../foo/bar

the issue is unrelated to the test page - i just picked an arbitrary public page which has dojo enabled.

Change History (6)

comment:1 Changed 9 years ago by ben hockey

comment:2 Changed 9 years ago by James Burke

Milestone: tbd1.6

comment:3 Changed 9 years ago by James Burke

Owner: changed from anonymous to James Burke

comment:4 Changed 8 years ago by bill

Milestone: 1.6future

(sadly) punting seemingly abandoned ticket and meta tickets to future

comment:5 Changed 7 years ago by bill

Component: CoreLoader
Owner: changed from James Burke to ben hockey
Status: newpending

I tried

dojo.registerModulePath('foo', '../../foo');
console.log(dojo.moduleUrl('foo').toString());

against http://download.dojotoolkit.org/release-1.4.0/dojo-release-1.4.0/dojo/tests/test_fx.html and it's printing out ../../../foo/, same as for 1.1 and 1.7.

Seems to be working for me, even against the version you specified. Is there something I missed?

Last edited 7 years ago by bill (previous) (diff)

comment:6 Changed 7 years ago by ben hockey

Priority: highlow
Resolution: worksforme
Status: pendingclosed

i can't seem to reproduce anything now and amd deprecates most of this.

Note: See TracTickets for help on using tickets.