Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#10682 closed defect (invalid)

Dojo dijit comboBox Issue in IE6

Reported by: anirbanhalder Owned by:
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.3.2
Keywords: comboBox IE6 dijit grid Cc:
Blocked By: Blocking:

Description

This is an issue in IE6 only. We have a JSP page in our application which has around 7 Dojo combo box. The page also loads couple Dojo Grids (dojox.grid.Grid) based on certain filter criteria in the combo boxes. We observed that initially when we click the dropdowns/combo boxes they open immediately (in less than 1 sec). But after the data is loaded in the grids on the same page, the combo boxes are taking more than 30 seconds to open on click. This does not happen in IE7 or IE8. Can you please help us to resolve this issue? Why combobox is taking so long to load when the page contains more widgets? Is it a IE6 limitation while working with certain amount of widgets in a page? We are using Dojo version 1.3.2 on IE6

Attachments (4)

test.js_File (131.8 KB) - added by anirbanhalder 9 years ago.
test.jsp_File (15.4 KB) - added by anirbanhalder 9 years ago.
test1.jsp_File (50 bytes) - added by anirbanhalder 9 years ago.
test_IE6.html (22.3 KB) - added by anirbanhalder 9 years ago.
Sample file:

Download all attachments as: .zip

Change History (16)

comment:1 Changed 9 years ago by Adam Peller

Version: 1.4.01.3.2

It's probably impossible to say without seeing your application. There are no known issues having a handful of comboboxes on your page, but if your grids and comboboxes are bound to dojo.data on a server, you may be experiencing I/O issues. Also, depending on how your grids are configured, they may have more in memory than necessary, sorts can be extremely expensive, etc.

Without a reproducible example, I suggest closing this, as there is no bug to investigate.

comment:2 Changed 9 years ago by anirbanhalder

Yes, our grids are bound to server using -

dojo.require("dojo.data.ItemFileReadStore?"); dojo.require("dojo.data.ItemFileWriteStore?");

Couple of source code files are attached. Hope this will give you more idea.

Also, what could be the reason its troubling in IE6 only and not in IE7 or IE8?

comment:3 Changed 9 years ago by bill

You said you attached source files, but you didn't.

comment:4 Changed 9 years ago by anirbanhalder

Attached the files. Thanks.

comment:5 Changed 9 years ago by bill

I see... hmm I can't look through 100K of JS and JSP. If you can make a small testcase in an HTML file I can take a look.

Changed 9 years ago by anirbanhalder

Attachment: test.js_File added

Changed 9 years ago by anirbanhalder

Attachment: test.jsp_File added

Changed 9 years ago by anirbanhalder

Attachment: test1.jsp_File added

comment:6 Changed 9 years ago by anirbanhalder

We are not sure if a smaller HTML test case can really explain our scenario. Our main question is, why this scenario is taking more time on IE6 like 20-30 sec(while its fraction on seconds in IE7 or IE8)? We are hoping the js file or the jsp will give you an idea how much components, widgets are loaded in the page. Thanks.

comment:7 Changed 9 years ago by anirbanhalder

@Dojo support team: Any comment on the above question?

comment:8 Changed 9 years ago by bill

IE6 is slow, it would be shocking if it _didn't_ take more time on IE6 than IE7. Although, 30x degradation is bad.

I'm not sure what's going on, and like I said I can't look through 100K of source.

Changed 9 years ago by anirbanhalder

Attachment: test_IE6.html added

Sample file:

comment:9 Changed 9 years ago by anirbanhalder

I've attached a sample HTML file (test_IE6.html), something similar to what our application page looks like. Please place the file under - dojo1.3.2\dojox\grid\compat\tests for execution.

Note - we have dojo.data calls in our application page, which I was not able to replicate in the above HTML. But, we are hoping that this test HTML will give you fair idea of what all widgets are included in our page.

You can also look at earlier uploaded test.js_File which is a 15k file.

comment:10 Changed 9 years ago by bill

Hmm, I tried your teset_IE6.html test case on IE6, it's got sub-second response (between clicking the down arrow and the combobox drop down list showing up).

I'm not clear if you actually built your ComboBox's using <option> tags, but if you did I guess it's worth trying some of the queries _ComboBoxDataStore does to see if they are running slowly, for example:

dojo.query("> option", dijit.byId("accountFilter3").store.root)

You could also just set up a debugger and step through the code to see what is taking so long.

comment:11 Changed 9 years ago by bill

Resolution: invalid
Status: newclosed

Sorry, I'm going to close this. We need a smaller test case before looking at it.

comment:12 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.