Opened 13 years ago

Closed 12 years ago

#1068 closed defect (fixed)

Editor interferes with dragging of FloatingPane

Reported by: jbowers_at_sd73.bc.ca Owned by: bill
Priority: high Milestone: 0.9
Component: Dijit Version: 0.3
Keywords: Editor FloatingPane Drag Cc:
Blocked By: Blocking:

Description

If I have an editor instance somewhere on the page, and I have a floating pane (toggled by some Toggler) somewhere, I cannot drag the floating pane to the very bottom of the page. It seems as though the FloatingPane? cannot figure out where the bottom limit of the page is because of the Editor (the floating pane seems to hit some sort of "invisible barrier")

Attachments (1)

float_editor_problem.html (6.4 KB) - added by jbowers_at_sd73.bc.ca 13 years ago.
Example HTML

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by jbowers_at_sd73.bc.ca

Attachment: float_editor_problem.html added

Example HTML

comment:1 Changed 13 years ago by dylan

Milestone: 0.5

comment:2 Changed 13 years ago by bill

Owner: changed from anonymous to liucougar

I suspect the editor's iframe is eating the mousemove events?

comment:3 Changed 12 years ago by bill

Component: WidgetsDijit
Milestone: 0.91.0
Owner: changed from liucougar to koranteng

In any case, this should be fixed with Dialog (which replaces FloatingPane?) because Dialog adds an invisible cover <div> over the whole page. Giving to Koranteng to check.

comment:4 Changed 12 years ago by bill

Owner: changed from koranteng to bill

comment:5 Changed 12 years ago by bill

Milestone: 1.00.9
Resolution: fixed
Status: newclosed

Confirmed this isn't an issue with Dialog and Editor (using themeTester.html) on FF2/mac.

Note: See TracTickets for help on using tickets.