Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#10676 closed defect (fixed)

[regression]popup not aligned in rtl

Reported by: Adam Peller Owned by: bill
Priority: high Milestone: 1.4.2
Component: Dijit Version: 1.4.0
Keywords: Cc: Dustin Machi, Douglas Hays
Blocked By: Blocking:

Description (last modified by Adam Peller)

Screen capture from themeTester.html?dir=rtl running in FF3.5.7

DateTextBox from themeTester.html?dir=rtl

Attachments (1)

popup.png (31.3 KB) - added by Adam Peller 9 years ago.
DateTextBox? from themeTester.html?dir=rtl

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by Adam Peller

Attachment: popup.png added

DateTextBox? from themeTester.html?dir=rtl

comment:1 Changed 9 years ago by Adam Peller

Description: modified (diff)

comment:2 Changed 9 years ago by Dustin Machi

I also tested http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/themes/themeTester.html?dir=rtl in safari and rtl is causing other problems there. They main layout container works, but the tab buttons/tabs don't show up.

comment:3 Changed 9 years ago by bill

Owner: set to bill
Status: newassigned

Looks like the same problem as [21108] but for Date/TimeTextBox?. I'll fix.

comment:4 Changed 9 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [21343]) Fix alignment of drop down for DateTextBox/TimeTextBox in RTL mode. Fixes #10676, refs #8948 !strict.

Could also move the marginBox() call (to set drop down width) before the call to dijit.popup.open(), but I've found setting a DOMNode size and then immediately querying the size to be unreliable on some browsers. (dijit.popup.open() queries the drop down size.)

comment:5 Changed 9 years ago by bill

PS: I filed the tab labels problem as a separate ticket, #10742.

Note: See TracTickets for help on using tickets.