Opened 10 years ago

Closed 10 years ago

#10663 closed defect (invalid)

dijit.Dialog forwards to another page after loading the href

Reported by: Eric Pokriefke Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.4.0
Keywords: dialog href firefox Cc:
Blocked By: Blocking:

Description

Case:

  1. Create a dijit.Dialog with a href attribute
  2. The external page which should be loaded by dijit.Dialog uses dojo and imports an external javascript file (<script type="text/javascript" src="foobar.js">)
  3. foobar.js uses one or more dojo.requires in global scope (no addOnLoad)

What happens:
In Firefox 3.5.7 you'll get forwarded to "wyciwyg://36/http://[address of the original page]" after the dialog is opened and the external page is loaded. The forward fails of course, which results in a blank screen.

In Opera, Safari, IE8 (latest versions) the dialog works as expected.
In IE6 and Chrome the Dialog will show you an error.

I've no clue what the problem is and it's a quite big problem for me. Of course I don't use a dojo.require in a global scope of a javascript file, but if you use a custom build, which loads the dojo/nls/myBuild_de-de.js files afterwards, you are facing this problem, too.

Change History (1)

comment:1 Changed 10 years ago by bill

Resolution: invalid
Status: newclosed

You can't load dojo again inside a Dialog, you need to use an iframe if you want to do that... although not sure why you would want to do that in the first place.

Note: See TracTickets for help on using tickets.