Opened 9 years ago

Closed 9 years ago

#10626 closed defect (duplicate)

Safari 4.0.4, OS X 10.5: dojo.query() returns a NodeList with not working shift() and splice() methods

Reported by: holgerthurow Owned by: anonymous
Priority: high Milestone: tbd
Component: General Version: 1.3.2
Keywords: dojo.query, NodeList, Safari Cc:
Blocked By: Blocking:

Description

To illustrate the problem I've provided a doh test at:

http://opixweb.opix.de/holger/dojo/queryTest.html

Change History (2)

comment:1 Changed 9 years ago by holgerthurow

Today I found similar problems with FF 3.5.3. It says "shift is not a function" and

doh.t(lis.splice(0, 1));

results in this error: "TypeError?: setting a property that has only a getter".

comment:2 Changed 9 years ago by James Burke

Resolution: duplicate
Status: newclosed

Marking this a duplicate of #9499, which is fixed in Dojo 1.4.

Note: See TracTickets for help on using tickets.