Opened 10 years ago

Closed 10 years ago

#10621 closed defect (fixed)

The blank http request cause performance on ie

Reported by: Eric Yan Owned by: James Burke
Priority: high Milestone: 1.5
Component: Core Version: 1.3.0
Keywords: performance Cc:
Blocked By: Blocking:

Description

When load compact dojo.js,it generates an blank request. Some pc take about 30 seconds to load this request ,the first time open it.

http://blog.httpwatch.com/2007/11/20/error_internet_invalid_url-httpwatch/comment-page-1/#comment-14186

Change History (2)

comment:1 Changed 10 years ago by James Burke

Milestone: tbd1.5
Owner: changed from anonymous to James Burke

This URL should not leave the browser, (you can verify by using a plain HTTP proxy like Charles).

If you comment out that suspect line in dojo.js does the 30 seconds go away?

Perhaps the issue is that it takes IE internally more time than it should to deal with the URL, recognize it as invalid.

I am hoping we will move away from this solution for Dojo 1.5. There is a discussion thread here: http://thread.gmane.org/gmane.comp.web.dojo.devel/12154

Also, in Dojo 1.4, you can set djConfig.skipIeDomLoaded = true to bypass the use of the odd URL. But it means all initialization will happen on window onload, after images and iframes load.

comment:2 Changed 10 years ago by James Burke

Resolution: fixed
Status: newclosed

Fixed as part of #10918

Note: See TracTickets for help on using tickets.