Opened 10 years ago

Closed 7 years ago

#10587 closed defect (fixed)

[patch][cla]dijit.Tree loosing nodes when dragging really fast

Reported by: nonken Owned by: nonken
Priority: high Milestone: 1.8
Component: Dijit Version: 1.4.0
Keywords: tree, dnd Cc: bill
Blocked By: Blocking:

Description

When opening http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/tree/test_Tree_DnD.html and moving around nodes of the left tree wildly, after some time a timing issue occurs and the dnd avatar does not disappear and the tree breaks.

Attached a patch which I'd like to discuss with Bill which seems to fix the issue but I am not entirely sure why this is happening

Attachments (2)

tree.png (20.1 KB) - added by nonken 10 years ago.
Screenshot of result of fast dnd operations
dndSource.patch (963 bytes) - added by nonken 10 years ago.

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by nonken

Attachment: tree.png added

Screenshot of result of fast dnd operations

Changed 10 years ago by nonken

Attachment: dndSource.patch added

comment:1 Changed 10 years ago by andyhot

I've noticed something similar (since 1.3.2) that matches the posted screenshot (i know i should have reported back then but i thought it was just me)

Anyway, what i had found (using FF & IE) is that the decribed problem usually occures when the dragging starts from the very left edge of a node - i can very easily reproduce the problem in the http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/tree/test_Tree_DnD.html examples

comment:2 Changed 9 years ago by Adam Peller

Summary: dijit.Tree loosing nodes when dragging really fast[patch][cla]dijit.Tree loosing nodes when dragging really fast

comment:3 Changed 9 years ago by Adam Peller

Milestone: 1.4.21.5

comment:4 Changed 9 years ago by bill

Milestone: 1.51.6

1.5 is released, moving remaining tickets to 1.6

comment:5 Changed 9 years ago by bill

See also #7971, may be related.

comment:6 Changed 8 years ago by bill

Milestone: 1.6future

comment:7 Changed 7 years ago by bill

Milestone: future1.8
Resolution: fixed
Status: newclosed

I think this is fixed by [28025].

Note: See TracTickets for help on using tickets.