Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1057 closed defect (invalid)

ComboBox -- type-ahead selecting from prior search argument

Reported by: guest Owned by: anonymous
Priority: high Milestone:
Component: Widgets Version: 0.3
Keywords: ComboBox Cc:
Blocked By: Blocking:

Description

I am using the ComboBox? 0.3.1 with the incrementalComboBoxDataProver with a searchDelay of 350 and noticed a type-ahead problem.

Test case #1: I quickly type in the name "smith," and noticed that 2 server requests were made, the output from the server is as follows: 1) search value ="smith" and list = "Smith I,Daniel James" , ... 2) search value ="smith," and list = "Smith,Adolphus", ...

But the problem is that ComboBox? text incorrectly shows "smith,I,Daniel James". Somehow the type-ahead got confused and selected the text from the first server request, when it should have taken it from the second request.

Test case #2: If I refresh my page, and repeat test case #1 but type faster and only 1 server request is made, the ComboBox? text correctly shows "smith,Adolphus"

Change History (3)

comment:1 Changed 13 years ago by guest

I entered the above ticket but and not working on it. Please assign it to someone to fix. sam.a.mager@…

comment:2 Changed 13 years ago by sam.a.mager@…

Resolution: invalid
Status: newclosed

I would like to add that the steps that I followed to consistently recreate this problem, upon demand are:

1) first enter "s" and I get "saa,Edward" in the textbox and list 2) backspace out "s" and I get "A'agular,Eleonora E" in the list 3) type in "smith," and I incorrectly get get "smith,I,Daniel James" in the textbox

I would also like to add that type-ahead behavior is important to us and becuase it does not work properly we cannot use the Dojo ComboBox?? widget until this issue is fixed.

comment:3 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.