Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#10551 closed defect (fixed)

[regression]Date picker cell with Datagrid

Reported by: Eric Pasquier Owned by:
Priority: high Milestone: 1.6
Component: DojoX Grid Version: 1.4.0
Keywords: Cc: Adam Peller, drs, Evan
Blocked By: Blocking:

Description

The example attached is working with 1.3.2 but not with 1.4.0. This is a simple date picker in a datagrid : on dblclick, the date picker goes at the left top corner and display January 1st, 1970 date (0000-00-00 ?). Same behavior with IE andFF.

I tried to have a look : The 'restore' function in dojox.grid.cells._base is continously called, which have 'this.value' set to null. The 'restore' function is called from 'render' in dojox.grid._View. Comparing with 1.3.2, the restore function is never called on DblClick?.

The only workaround I found is to put the 1.3.2 grid branch in the 1.4.0 version...

Attachments (1)

testdate.htm (2.8 KB) - added by Eric Pasquier 9 years ago.

Download all attachments as: .zip

Change History (12)

Changed 9 years ago by Eric Pasquier

Attachment: testdate.htm added

comment:1 in reply to:  description Changed 9 years ago by Eric Pasquier

Making a comparison with one of the test case, I discovered that setting autoHeight=true cause the problem.

It may be link to Ticket #9261:dojox.DataGrid? autoHeight parameter causes infinite Loop/flickering/100% Cpu utilization, but it's working with 1.3.2.

Eric.

comment:2 Changed 9 years ago by Adam Peller

Cc: Adam Peller added

comment:3 Changed 9 years ago by Adam Peller

Cc: drs evan added
Milestone: tbd1.4.1

comment:4 Changed 9 years ago by Adam Peller

Summary: Date picker cell with Datagrid[regression]Date picker cell with Datagrid

comment:5 Changed 9 years ago by rahman

My work around for above issue is to comment out one line

this.grid.rowHeightChanged(inRowIndex); in dojox.grid.cells._Widget => formatNode method.

There better solution would be to break the circular dependency between rowHieghtChanged and formatNode methods.

comment:6 Changed 9 years ago by Adam Peller

Milestone: 1.4.21.5
Priority: normalhigh

comment:7 Changed 9 years ago by Nathan Toone

Milestone: 1.5future
Owner: Nathan Toone deleted

Moving my tickets to future, as I am not currently working on them.

comment:8 Changed 8 years ago by evan

Milestone: future1.6
Resolution: fixed
Status: newclosed

Closing this. The infinite Loop/flickering/100% Cpu utilization was already fixed by [22903] of #9261.

Not able to reproduce the issue of wrong position of Calendar(left top corner) with 1.6b1.

comment:9 Changed 8 years ago by Eric Pasquier

Yes the position is correct. But you now have to click 3 times, instead of 2, to open the DatePicker? : at the second click, you only get an empty combo box displayed.

comment:10 in reply to:  9 Changed 8 years ago by Eric Pasquier

Replying to Eric P:

Yes the position is correct. But you now have to click 3 times, instead of 2, to open the DatePicker? : at the second click, you only get an empty combo box displayed.

Reported in new ticket #12195

comment:11 Changed 8 years ago by Evan

Cc: Evan added; evan removed
Note: See TracTickets for help on using tickets.