Opened 9 years ago

Closed 9 years ago

#10550 closed defect (invalid)

Firefox Internal Error "Component returned failure code"

Reported by: Ran Mory Owned by: anonymous
Priority: high Milestone: tbd
Component: Dijit Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

I have a dojo class 'MyClass' below :

dojo.declare(
            "MyClass",
            dijit._Widget,
            {
                 gabarit: null,
                 constructor: function (gabarit) {
                    if (gabarit == "[object HTMLDocument]") {
                        this.gabarit = gabarit;
                    }
                    console.log(this.gabarit);
                    
                },

I created an object DomDocument by 'document.implementation.createDocument' then I pass it as a parameter to the constructor of MyClass?, then it gives me the console.log(this.gabarit) of it is a domDocument then it gives me this error :

uncaught exception: [Exception... "Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIDOM3Document.domConfig]" nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)" location: "JS frame :: http://localhost/MyWorkspace/Test/dojo/dojo/dojo.js :: anonymous :: line 16" data: no]

while the error block the code after the constructor? so Where does this error message come from?

Change History (1)

comment:1 Changed 9 years ago by bill

Component: GeneralDijit
Description: modified (diff)
Resolution: invalid
Status: newclosed

If you are extending _Widget than you need to follow the pattern for the constructor of

constructor(args, domNode)

For example:

new MyClass({name: "hello world},  myDomNode);

Presumably that's the cause of your error.

Note: See TracTickets for help on using tickets.