Opened 9 years ago

Closed 9 years ago

#10548 closed enhancement (wontfix)

dojox.form.PasswordValidator pwType="old" reports "Invalid Password" before calling pwCheck

Reported by: coldfire22x Owned by: dante
Priority: high Milestone: tbd
Component: DojoX Form Version: 1.4.0
Keywords: Cc:
Blocked By: Blocking:

Description

The way the PasswordValidator? verifies the old password is somewhat misleading.

If you focus the old password textbox and type in the first character of your (old) password, it immediately reports "Invalid Password" as though it's performing the check after every character that is input. However, it does not actually fire the pwCheck event until after blur.

I propose that it not report "Invalid Password" until the pwCheck event has fired and confirmed that the password is valid or invalid. Let me know what you think, thanks!

Change History (2)

comment:1 Changed 9 years ago by bill

Component: GeneralDojoX Form
Owner: changed from anonymous to dante

comment:2 Changed 9 years ago by dante

Resolution: wontfix
Status: newclosed

I'm hesitant to change this behavior because of the complication it would introduce into the hasbeenblurred/wherearewe logic going on. Would gladly welcome a patch with prototype behavior.

Note: See TracTickets for help on using tickets.