Opened 9 years ago

Closed 9 years ago

#10514 closed defect (invalid)

Windows XP Setup Causing Intermittent (but constant) problems with HiTask

Reported by: ajmccann Owned by: anonymous
Priority: high Milestone: tbd
Component: General Version: 1.4.0
Keywords: Cc:
Blocked By: Blocking:

Description

I'm hoping to get some help...

My company's XP image has an issue with HiTask?.com, which I'm assuming has something specific to do with Dojo.

Sometimes the hitask.com page doesn't load, and saving is always a problem. It's as if the connection drops in and out. I've contacted HiTask? about this, but because the site is working fine on my other computers, there is little that they want to do.

The issue is consistent across all our work computers and all browsers. The only exception is the Macs that we have. They work fine. All other websites (we're big users of web 2.0) work just fine. We've never experienced anything like this.

Is there anything in the Windows XP setup that can affect a dojo-based site? We'd really like to become customers of HiTask?...but obviously can't if the site hardly works.

Change History (4)

comment:1 Changed 9 years ago by James Burke

Resolution: invalid
Status: newclosed

What browser is a problem on XP? If you use IE 8.0 with the Developer Tools on, do you see any errors? If in Firefox you can use Firebug to look for errors.

Out of the box Dojo should work fine in Windows XP, there is no Windows XP-specific logic.

I just tried a test account on the site. I tried with Firefox 3.6 beta 4, and it looks like they have some errors on the tutorial page: http://hitask.com/tutorial?AS=XXXXXXXXXXXXX

It looks like they are referencing some Dojo 0.4 code, but then if I go to this page: http://hitask.com/hi?AS=XXXXXXX

it seems to load fine without any errors and it looks like they are using Dojo 1.x on that page.

So if the errors you are seeing are on the tutorial page, then I think they just have some code dependency problems on the page.

I am going to close this ticket out since I believe it to be a problem with the site. If you have more information about specific failures and specific browsers then feel free to add that info to the ticket, but at first blush, looking at the tutorial page it looks like a packaging/version mix-up on their site.

comment:2 Changed 9 years ago by ajmccann

Resolution: invalid
Status: closedreopened

Thanks so much for taking a look and for your reply.

The issue has to be connected to the XP image on our work computers (which doesn't rule out an error in the HiTask? code). HiTask? works perfectly with my home computers, and with Macs with our work Mac image.

The problem is intermittent loads (sometimes the homepage won't load...then it does when you refresh) and more particularly trying to save changes to tasks/projects.

I installed IE8 and ran developer tools. Here are some of the 'errors' that show in the console in debugging mode:

Error: Unable to load /data/ptitle status:12029

Error: Unable to load /api/update?time=2009-12-16%2013%3A04%3A48&time_zone=America%2FNew_York&team_time=1260811263&json=1&apiKey=web1&apiVersion=1.1&A

comment:3 Changed 9 years ago by ajmccann

PS: The issue affects all 4 browsers I've tried: Ff, Safari, Chrome, and IE. All most recent versions.

comment:4 Changed 9 years ago by James Burke

Resolution: invalid
Status: reopenedclosed

OK, that sounds like a problem with the networking stack in the XP image. According to this page: http://wiki.motionbased.com/mb/HTTP_status_12029

status 12029 seems to imply firewall issues or some sort of networking issues. This would make sense since the issue is only with that image not on other boxes.

Note: See TracTickets for help on using tickets.