Opened 10 years ago

Closed 7 years ago

#10484 closed defect (fixed)

grids inside of dialogs don't work

Reported by: Mignon Belongie Owned by: Evan
Priority: high Milestone: 1.8
Component: DojoX Grid Version: 1.5
Keywords: grid dialog Cc:
Blocked By: Blocking:

Description (last modified by Mignon Belongie)

See dojo-release-1.5.0-src\dojox\grid\tests\test_grid_dlg.html for an example of it not working.

Change History (9)

comment:1 Changed 10 years ago by bill

Version: 0.4.11.4.0

comment:2 Changed 10 years ago by bill

I don't really understand the grid resizing code (see [17305] for recent changes), but it seems odd that there's no size specified on the grid and yet autoHeight is set to false when I trace through the code.

comment:3 Changed 9 years ago by Nathan Toone

Owner: Nathan Toone deleted

Unassigning my tickets.

comment:4 Changed 9 years ago by Mignon Belongie

Description: modified (diff)
Version: 1.4.01.5

comment:5 Changed 9 years ago by Elvis

Has checked this reported bug based on the test page, found that actually it's not a bug of grid resizing, but a defect of this test page. The height of dialog's content, i.e. grid's parent dom node, is 0 when the page initializing, and the grid would be trying to resize itself to fit its parent, so that grid was displayed incorrectly when dialog showing up.

Here are a couple of ways to fix this defect:

  1. Set the height for the grid's parent dom node
  2. Set the widht/height for the grid's dom node via "style" attribute to avoid grid to fit its parent
  3. Set the grid.height attribute

comment:6 Changed 8 years ago by evan

Milestone: tbd1.7
Owner: set to evan

comment:7 Changed 8 years ago by evan

Priority: highnormal
severity: criticalnormal

comment:8 Changed 8 years ago by evan

Owner: changed from evan to Evan

comment:9 Changed 7 years ago by Evan

Resolution: fixed
Status: newclosed

In [28105]:

Fixes #10484, though it's more like a workaround, Grid needs an explicit height, but in this test case, grid.domNode.ClientHeight? is always 0 if without this fix.

Note: See TracTickets for help on using tickets.