Opened 10 years ago

Closed 10 years ago

#10463 closed defect (fixed)

Chrome does not set Editor contents in onload deferred callback function

Reported by: ghannes Owned by:
Priority: high Milestone: 1.4
Component: Editor Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

Chrome browser version 3.0.195.33 dojo 1.3.2 windows xp home 5.1.2600 sp3 build 2600

Chrome browser should set the editor contents in the onload deferred callback function, but it does not. If the same program is tested in other browsers, it works fine.

I've attached the html source , and a document explaining the issue Also a live example is available with URL: http://itnbuilder.eu/dojotest/tEditor.html

In other browsers (IE8 - 8.0.6001.18702 on windows xp home 5.1.2600 sp3 build 2600; FF 3.5; . . .) this issue does not appear

Attachments (2)

tEditor.html (1.8 KB) - added by ghannes 10 years ago.
source html file
Chrome_does_not_set_editor_contents_correctly.doc (112.5 KB) - added by ghannes 10 years ago.
document to reproduce the issue

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by ghannes

Attachment: tEditor.html added

source html file

Changed 10 years ago by ghannes

document to reproduce the issue

comment:1 Changed 10 years ago by bill

Milestone: tbd1.4
Resolution: fixed
Status: newclosed

Thanks for the test case.

I reproduced the failure in 1.3, but it's already working fine in 1.4.

BTW, not everyone has MS Word, it would be helpful if you just write the complete description of the problem in the description field. In this case the problem was that onLoadDeferred.addCallback(...setValue(...) ) didn't set the value on chrome.

Note: See TracTickets for help on using tickets.