Opened 10 years ago

Closed 6 years ago

#10462 closed defect (wontfix)

IE8 (windows 7) hangs with 2 iFrames when returning to main window

Reported by: ghannes Owned by:
Priority: high Milestone: 1.9
Component: Dijit Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

(also refer to ticket #9726). I have a parent window with 2 iFrames. The 1st (upper) iframe is loaded, then the 2nd iframe (in this sequence), then press on the Go back button in the 1st iFrame, IE8 hangs for several minutes and the script needs to be stopped.

Strange is that this only seems to occur in some (not all) IE8 browser versions. I've at least 1 case where I can re-produce the issue on windows7 with IE8:

Windows 7 - Home premium IE8 - version 8.0.7600.16385 dojo release 1.3.2

I've uploaded the source files: tIframe.php, tIframeClient.php and tIframeClient2.php; and a document explaining how to reproduce the issue. A live test case is also available on URL: http://itnbuilder.eu/dojotest/tIframe.php

Note (from ticket #9726), type="button" is specified in the <button> tags.

The same program is tested OK, with following browsers: FF 3.0.15, FF 3.5 Chrome 3.0.195.33

and even IE7/IE8 with different browser versions are ok: IE8 - 8.0.6001.18702 on win xp home 5.1.2600 SP3 build 2600 IE7 - 7.0.5730.13 on win xp prof. 5.1.2600 SP3 build 2600

Maybe it depends on some settings in the IE8 browser ?

Note As an alternative in IE8, i did install google Chrome Frame plugin and made it active (for testing reasons) through following meta tag <meta http-equiv="X-UA-Compatible" content="chrome=1"> This solves the issue in IE8 in windows7 environment, but then the system is tuned into (partially) a google chrome browser.

( http://code.google.com/intl/nl-BE/chrome/chromeframe/ )

Attachments (2)

tIframe.zip (3.7 KB) - added by ghannes 10 years ago.
source files
IE8_hangs_WIN7_iFrame.doc (136.0 KB) - added by ghannes 10 years ago.
document on how to reproduce

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by ghannes

Attachment: tIframe.zip added

source files

Changed 10 years ago by ghannes

Attachment: IE8_hangs_WIN7_iFrame.doc added

document on how to reproduce

comment:1 Changed 9 years ago by James Burke

Component: GeneralDijit
Owner: anonymous deleted

comment:2 Changed 7 years ago by bill

Milestone: tbd1.9

comment:3 Changed 6 years ago by bill

Resolution: wontfix
Status: newclosed

At least it works on Win7/IE9 on trunk and (according to you WinXP/IE8). When running on 1.3 I get errors about "tried to register widget with id "pane1" but that id is already registered". So maybe it's been fixed since then?

Even if this is still an issue in trunk, it's not worth fixing since the ticket is so old and since presumably on Win7 has been upgraded to IE9 or IE10.

Note: See TracTickets for help on using tickets.