Opened 13 years ago

Closed 13 years ago

#1044 closed defect (duplicate)

splitcontainer doesnt resize when using iframe

Reported by: guest Owned by: anonymous
Priority: high Milestone: 0.9
Component: Widgets Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

if i have a split container that holds a content pane which holds an iframe, i am unable to resize the split container if i force the size of the iframe to be 100%. if i dont force the size of the iframe the resizing works but only part of the iframe is visible, see below

<div dojoType="SplitContainer?"

id="rightPane" orientation="vertical" sizerWidth="5" activeSizing="0" sizeMin="50" sizeShare="80">

<div dojoType="ContentPane?" sizeMin="20" sizeShare="30">

<table width="100%">

<tr>

<td align="center" valign="top">

<iframe name="bodyFrame" title="bodyFrame" frameborder="0" style="height:100%;width:100%;"></iframe>

</td>

</tr>

</table>

</div>

</div>

</div>

Change History (3)

comment:1 Changed 13 years ago by dylan

Milestone: 0.5

comment:2 Changed 13 years ago by bill

See also #2000

comment:3 Changed 13 years ago by koranteng

Resolution: duplicate
Status: newclosed

Duplicate of #2000 and #1229

fixed (In [7453]) by introducing a div to cover the entire area occupied by a splitcontainer. the div is under the sizer

Note: See TracTickets for help on using tickets.