Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#10416 closed defect (wontfix)

AccordionContainer: flickering during opening (FF)

Reported by: kiuma Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.4.0b
Keywords: Cc:
Blocked By: Blocking:

Description

Change History (3)

comment:1 Changed 9 years ago by bill

Resolution: wontfix
Status: newclosed
Summary: dijit.layout.AccordionContainer flickeringAccordionContainer: flickering during opening (FF)

On FF3.5/win I see that, during the wipe-in animation, the content of the pane is momentarily visible below the AccordionContainer, overlaying the text below the AccordionContainer. Is that the problem you mean?

I thought we had fixed this but I guess not. I see it occurs in 1.2 and 1.3 too, so it's not a regression.

The problem is fixed in Firefox 3.7 alpha so realistically I don't think we'll check in a fix to this in dijit, unless you know some simple CSS change that makes it work.

comment:2 Changed 9 years ago by kiuma

I confirm that on FF 3.7 seems to be resolved, but I think that animating on position instead of dimension would result more fluid. ...it should be

comment:3 Changed 9 years ago by bill

Thanks.

Animating on position might be better; but I'm think I tried that on one point and ran into problems. Remember that during an animation there's both an opening pane and a closing pane, and as one gets "bigger" the other needs to be getting "smaller".

There's also a style change in the works where the open pane will have a border all the way around it (see the lucid spec), so not sure if that will affect things either.

Note: See TracTickets for help on using tickets.