Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#10401 closed defect (fixed)

[regression] TabContainer: tests/layout/test_Gui.html not rendering properly in Firefox on Mac

Reported by: PlatisYialos Owned by: bill
Priority: high Milestone: 1.4
Component: Dijit Version: 1.4.0b
Keywords: Cc:
Blocked By: Blocking:

Description

  • Dojo 1.4 RC1
  • Firefox on Mac -->> Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

Invoke the test dojoroot/dijit/tests/layout/test_Gui.html on Firefox on the Mac.

  • ContentPane? with id="basdicFormTab" is not displayed properly on load. Looks OK after resizing the browser. This worked properly in the beta2 release.
  • Similarly, at the bottom of the page, "BorderContainer? in Tabs" not rendering properly.
  • The top region is not displayed properly. The problem is also evident in the beta2 release.

These issues do *not* occur on Safari Version 4.0.4 (5531.21.10) running on the same machine.

Change History (5)

comment:1 Changed 10 years ago by bill

Milestone: tbd1.4
Owner: set to bill
Status: newassigned
Summary: dojoroot/dijit/tests/layout/test_Gui.html not rendering properly in Firefox on Mac[regression] TabContainer: tests/layout/test_Gui.html not rendering properly in Firefox on Mac

Good catch, thanks for filing the ticket.

The problem with the top tabs and the bottom tabs started in [20710] to fix #10113, a doLayout=false width problem. I'll make the CSS rule more specific to only hit the doLayout=false case.

comment:2 Changed 10 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [20906]) Only apply the width: 100% in doLayout=false mode, to fix rendering problems when a TabContainer is embedded in a BorderContainer.

Fixes #10401, refs #10113 !strict.

comment:3 Changed 10 years ago by bill

I fixed the problems that occurred after beta2. I don't see the issue your are talking about with "The top region is not displayed properly. The problem is also evident in the beta2 release.".

comment:4 Changed 10 years ago by platisyialos

I tested the TabContainer? fix using the November 26 build, and it works for me on my Firefox. I'm also confirming that it still works on my Safari browser.

Thanks for the quick turnaround.

comment:5 Changed 10 years ago by platisyialos

This is weird!

When I fired up the browser to test the TabContainer? defect, the issue I reported above regarding the top region manifested itself, again.

I resized the browser, the region rendered itself fine. I deleted my cache, closed the browser, went to the page again, the top region renders fine.

I can't reproduce the issue anymore. If I find a way to reproduce it, I'll open another ticket.

Thanks for your help.

Note: See TracTickets for help on using tickets.