Opened 16 years ago

Closed 16 years ago

#104 closed defect (wontfix)

Should isUndefined be renamed to isDefined?

Reported by: Michael Schall Owned by: alex
Priority: low Milestone:
Component: General Version: 0.0
Keywords: Cc:
Blocked By: Blocking:


In the dojo javascript sytle document, the following talks about variables. Does this extend to function names.

# Negated boolean variable names MUST be avoided: isNotError, isNotFound are unacceptable.

Change History (2)

comment:1 Changed 16 years ago by dylan

undefined is a standard JS value type, so I don't think so. isNotUndefined on the other hand would be really bad. In this case, changing the name to be inconsistent with JS sounds silly.

comment:2 Changed 16 years ago by [email protected]

Resolution: wontfix
Status: newclosed

What Dylan said.

Note: See TracTickets for help on using tickets.