Opened 9 years ago

Closed 9 years ago

#10397 closed defect (fixed)

Tooltip: pointer is not visible in high contrast mode

Reported by: Becky Gibson Owned by: bill
Priority: high Milestone: 1.5
Component: Accessibility Version: 1.4.0b
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Becky Gibson)

Affected Browsers: IE7, IE8

Steps to Reproduce: 1.- Set Use High Contrast and select a scheme (High Contrast # 1 (Large))

2.- Open the browser

3.- Enter dijit/tests/test_TooltipDialog.html

4.- Focus on a ToolTipDialog? invoking button

5.- Press Space, Enter or Down narrow to open the ToolTipDialog?

Note that the pointer is not displayed.

Actual Result : ToolTipDialog? is displayed incomplete. Expected result: ToolTipDialog? should be displayed complete.

Attachments (1)

tooltipNoPointerHC.JPG (58.0 KB) - added by Becky Gibson 9 years ago.

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by Becky Gibson

Attachment: tooltipNoPointerHC.JPG added

comment:1 Changed 9 years ago by Becky Gibson

Description: modified (diff)

comment:2 Changed 9 years ago by bill

This is expected behavior, since the pointer is implemented using a background-image? I'd like to close this as "wontfix" unless you have some plan about how to make the pointer show up?

We could add rules though to eliminate that gap in the border where the pointer is supposed to be.

comment:3 Changed 9 years ago by bill

Milestone: future1.5
Owner: changed from Becky Gibson to bill

I'll fix the gap problem for 1.5, should be a trivial change.

comment:4 Changed 9 years ago by bill

Resolution: fixed
Status: newclosed

(In [20982]) Hide tooltip connect (arrow graphic) in high contrast mode because background-images don't show up in that mode (and because it causes a break in the border of the tooltip). Fixes #10397 !strict.

Note: See TracTickets for help on using tickets.