Opened 9 years ago

Closed 6 years ago

Last modified 6 years ago

#10393 closed enhancement (fixed)

Dojo GFX Enhancement - Introduce Batch api for performance

Reported by: Chris Mitchell Owned by: Eugene Lazutkin
Priority: high Milestone: 1.9
Component: DojoX GFX Version: 1.4.0b
Keywords: Cc:
Blocked By: Blocking:

Description

As part of the SVGWeb for GFX work, Yang Li, an IBM engineer has found that the load times of the complex scene scenarios (esp. w/r/t the SVG renderer) can be significantly reduced (30-35%) using DOMFragment api. In order to use the DOMFragment api, we need to expose an api to allow application control over when operations on a scene will become active, such as a batch api. Yang is proposing two options for this feature, and has prototyped the first (see attachment).

Change History (5)

comment:1 Changed 9 years ago by Eugene Lazutkin

Milestone: tbd1.5
Status: newassigned

comment:2 Changed 9 years ago by Eugene Lazutkin

Milestone: 1.5future

Should be implemented for all renderers. Additionally it should be reconciled with the existing batching of the canvas renderer.

comment:3 Changed 6 years ago by Patrick Ruzand

#13931 is a duplicate of this ticket.

comment:4 Changed 6 years ago by Patrick Ruzand

Resolution: fixed
Status: assignedclosed

fixed by #9948 and #16454

comment:5 Changed 6 years ago by bill

Milestone: future1.9
Note: See TracTickets for help on using tickets.