Opened 10 years ago

Closed 10 years ago

#10392 closed defect (fixed)

ContentPane: changing title (to change tab label) puts tooltip over entire pane

Reported by: mark007 Owned by: bill
Priority: high Milestone: 1.4
Component: Dijit Version: 1.4.0b
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

I have created a very basic webpage containing a TabContainer? and some ContentPanes?. Each ContentPane? is used to represent an item in a mailbox, like "Inbox", "Outbox" etc.

So for example I might have the following title on my Inbox, which would have 3 new messages

title="<b>Inbox (3)</b>"

This looks perfect, but no matter where I hover my mouse in this Content Pane, in any web browser, this raw title gets shown as a popup, ie "<b>Inbox (3)</b>"

I don't see a way to disable this so I am filing it as a bug. I think either a popup should be made optional, or the mandatory popup should gobble up the html title to display nicely and not show the html tags that may appear in a title.

This is with dojo 1.4rc1

Change History (10)

comment:1 Changed 10 years ago by bill

Milestone: 1.4tbd
Resolution: worksforme
Status: newclosed

I tried http://download.dojotoolkit.org/release-1.4.0b2/dojo-release-1.4.0b2/dijit/tests/layout/test_TabContainer.html on safari and it's working fine for me, no unwanted tooltips are displayed.

Please attach test cases to all your tickets and also, don't set the milestone, thanks! If you have a test case that reproduces this you can reopen the ticket after attaching the test case with the "attach file" button.

comment:2 Changed 10 years ago by mark007

Resolution: worksforme
Status: closedreopened

OK, it seems to be activated when updating an existing title.

1) Go to the following page http://download.dojotoolkit.org/release-1.4.0b2/dojo-release-1.4.0b2/dijit/tests/layout/test_TabContainer.html 2) Hover over one of the tab contents on the first test tabcontainer, no hover text will be shown 3) Rename the tab with one of the buttons. Now the hover text will be shown all over the contentPane. If html tags were included in the title during the update, these tags would be literally shown when hovering also.

This doesn't seem like it was intended behaviour. Cheers.

comment:3 Changed 10 years ago by mark007

PS: If users shouldn't set the milestone, can this ability be removed.

comment:4 Changed 10 years ago by bill

Milestone: tbd1.4
Owner: set to bill
Status: reopenednew
Summary: ContentPane Title Popping Up On HoverContentPane: changing title (to change tab label) puts tooltip over entire pane

Ah OK, thanks for the steps to reproduce.

So changing the title is the problem. This is really part of #7708, a problem with that new feature.

ContentPane.postCreate() has this code in postCreate():

// remove the title attribute so it doesn't show up when hovering
// over a node
this.domNode.title = "";

However changing the title isn't handled. I guess we need to a _setTitleAttr() method that just sets the property, like:

_setTitleAttr: function(title){
   this.title = title;
}

About the milestone setting: I'd like to limit that feature to committers but we don't have the time/expertise right now to tweak trac; hopefully someday.

comment:5 Changed 10 years ago by bill

Resolution: fixed
Status: newclosed

(In [20908]) Don't copy title parameter to ContentPane.domNode because it will show up as a tooltip when mouse is anywhere over the whole pane. Refs #7708, fixes #10392, !strict.

comment:6 Changed 10 years ago by mark007

cheers bill, nice fix :D

comment:7 Changed 10 years ago by mark007

Resolution: fixed
Status: closedreopened

Hi Bill,

This seems fixed for IE7 and FF 3.5, but testing in Chrome 3 and 4 nightlies doesn't seem to be fixed.

This is using dojo nightly from lastnight. Is your fix browser specific? Reopening to have it investigated for Chrome 3 and 4. Thanks.

comment:8 Changed 10 years ago by bill

Nope, it's not browser specific. Maybe you forgot to clear your cache? Running http://download.dojotoolkit.org/release-1.4.0rc2/dojo-release-1.4.0rc2/dijit/tests/layout/test_TabContainer.html on both Safari4/mac and Chrome4/win, I don't see a tooltip over the content even after pressing the "Rename Tab #2" button. Do you?

comment:9 Changed 10 years ago by mark007

Sorry you were right. No amount of refreshing fixed the issue. I had to clear the cache of chrome. I assume every user of my pages that are effected by things like this, will never see the update page until they clear their caches.

Probably this problem would lie with chrome developers..?

Thanks again.

comment:10 Changed 10 years ago by bill

Resolution: fixed
Status: reopenedclosed

Refreshing doesn't reload javascript, it just reloads the main page.

Of course that depends on your web server settings and when the javascript is set to expire, etc. etc.

Note: See TracTickets for help on using tickets.