Opened 10 years ago

Closed 10 years ago

#10375 closed defect (fixed)

[regression]: dojox.math.round test fails on IE7

Reported by: Douglas Hays Owned by: Adam Peller
Priority: high Milestone: 1.4
Component: Dojox Version: 1.4.0b
Keywords: Cc: Adam Peller, Eugene Lazutkin
Blocked By: Blocking:

Description

I'm running dojox/math/tests/runTests.html on IE7 and getting 1 failure. Unfortunately the test worked in Dojo 1.3.

GROUP "dojox.math.tests.round" has 3 tests to run     _AssertFailure: [object Error]: assertEqual() failed:  
expected -162.29 but got -162.3  
[object Error]     ERROR IN:  function(t){ t.is(0, dojo.number.round(0)); t.is(1, dojo.number.round(0.5)); t.is(-1, dojo.number.round(-0.5)); t.is(0.1, dojo.number.round(0.05, 1)); t.is(-0.1, dojo.number.round(-0.05, 1)); t.is(1.1, dojo.number.round(1.05, 1)); t.is(-1.1, dojo.number.round(-1.05, 1)); t.is(-162.29, dojo.number.round(-162.295, 2)); t.is(162.29, dojo.number.round(162.295, 2)); } 
FAILED test: round 0 ms

It looks like [18740] changed the test.

Change History (4)

comment:1 Changed 10 years ago by Adam Peller

Milestone: tbd1.4

comment:2 Changed 10 years ago by Tom Trenka

(In [20922]) Fixed the references in the test (they were pointing at dojo.number.round, and should have been pointing at dojox.math.round). Refs #10375, !strict.

comment:3 Changed 10 years ago by Tom Trenka

Owner: changed from Tom Trenka to Adam Peller

Actually, r.18740 didn't change the test itself; it was just a re-org of the dojox.math namespace (to include the stats package); it's looking to me like that failure was already there before that.

Fixed the test so that it's actually testing against dojox.math.round (it was running against dojo.number.round) but re-assigning back to peller to see if he can figure out the issue.

comment:4 Changed 10 years ago by Tom Trenka

Resolution: fixed
Status: newclosed

(In [20923]) Fixed the round assertions. Fixes #10375, !strict.

Note: See TracTickets for help on using tickets.