Opened 9 years ago

Closed 9 years ago

#10367 closed defect (fixed)

dojox.editor.plugins.PrettyPrint Error

Reported by: youngho Owned by: Jared Jurkiewicz
Priority: high Milestone: 1.4
Component: Editor Version: 1.4.0b
Keywords: Cc:
Blocked By: Blocking:

Description

Hello,

Open the PrettyPrint? test screen with FF.

http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/editor/tests/editorPrettyPrint.html

click the editor area, and than click the outside area of the editor.

Than

self.editor._localizedIframeTitles is undefined occurs.

Change History (12)

comment:1 Changed 9 years ago by Jared Jurkiewicz

Resolution: worksforme
Status: newclosed

I don't see this problem occur in the latest nightly using FireFox? 3.0.15. All I did was open the editor as noted, click in the edit area first thing, then clicked outside.

No errors.

Same for FireFox? 3.5.5

Closing as WorksForMe?.

comment:2 Changed 9 years ago by mark007

Resolution: worksforme
Status: closedreopened

I confirm this in firefox 3.5.5. Error console shows the error reported

self.editor._localizedIframeTitles is undefined

comment:3 Changed 9 years ago by Jared Jurkiewicz

It's working for me. You will have to provide better reproduction steps as I cannot trigger it.

1.) What operating system is running your browser? 2.) What are the exact steps you are doing? Which panes do you show and hide, etc.

comment:4 Changed 9 years ago by mark007

Using both Windows 7 64bit, and Windows Vista 32bit I can reproduce.

Steps 1) Open page in firefox 2) Open Tools - Error Console 3) Go to error section and hit clear. 4) Click something like the text that says "1. One" 5) Click the title of the page that says "Editor + PrettyPrint? Plugin" 6) See the error in Error Console

comment:5 Changed 9 years ago by mark007

Actually even leave out step 5, not required.

comment:6 Changed 9 years ago by mark007

Actually even loading that page throws errors, dijit is not defined........

comment:7 Changed 9 years ago by Jared Jurkiewicz

Ah, this is caused by a change Becky made:

http://trac.dojotoolkit.org/ticket/10232

Need to remove the PP ref to it.

Not sure why I never see the error. Bizarre.

comment:8 Changed 9 years ago by Jared Jurkiewicz

Resolution: fixed
Status: reopenedclosed

(In [20886]) Fixing error thrown due to A11Y change. fixes #10367

comment:9 Changed 9 years ago by Jared Jurkiewicz

Milestone: tbd1.4

comment:10 Changed 9 years ago by Jared Jurkiewicz

Resolution: fixed
Status: closedreopened

comment:11 Changed 9 years ago by Jared Jurkiewicz

Owner: set to Jared Jurkiewicz
Status: reopenednew

comment:12 Changed 9 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.