Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1035 closed defect (fixed)

Support for Embedded iframes in PopupMenu2

Reported by: liucougar Owned by: anonymous
Priority: high Milestone:
Component: General Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

In order to support context menu in enhanced Editor, specifying an iframe as the target node of a PopupMenu2 is required. This patch implemented this

Attachments (2)

1035.patch (8.6 KB) - added by liucougar 13 years ago.
1035-2.patch (1.4 KB) - added by liucougar 13 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 13 years ago by liucougar

dojo.lang.forEach is not used, because I need to break from the loop, and the variable I want to set is a local varaible, which is not accessible in dojo.lang.forEach

Changed 13 years ago by liucougar

Attachment: 1035.patch added

comment:2 Changed 13 years ago by psowden

Resolution: fixed
Status: newclosed

Fixed in r4536.

comment:3 Changed 13 years ago by psowden

Milestone: 0.4

Changed 13 years ago by liucougar

Attachment: 1035-2.patch added

comment:4 Changed 13 years ago by liucougar

the second patch fixed a regression in tests/widget/test_Button.html

in addition, fixed onscoll issue with IE

comment:5 Changed 13 years ago by liucougar

a modified patch is committed in r4538

comment:6 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.