Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#10337 closed defect (wontfix)

Opera 10: dojo adds <br/>

Reported by: webmaser Owned by: James Burke
Priority: low Milestone: tbd
Component: General Version: 1.3.2
Keywords: Opera 10 Cc:
Blocked By: Blocking:

Description

Every page, where is called just something like

<script type="text/javascript" src="/js/dojo/dojo.js"></script>

dojo adds <br/> behing <html> tag in Opera 10

screen

Change History (12)

comment:1 Changed 10 years ago by James Burke

Resolution: worksforme
Status: newclosed

I just tried this URL: http://download.dojotoolkit.org/release-1.3.2/dojo-release-1.3.2/dojo/tests/_base/_loader/addLoadEvents.html

and I do not see any extra BR tags using Opera 10.1 on windows and inspecting the DOM with Opera's Dragonfly inspector. Feel free to reopen with more details.

comment:2 Changed 10 years ago by bill

Priority: highestlow
Resolution: worksforme
severity: criticalminor
Status: closedreopened
Summary: Opera 10 bug, dojo adds <br/>Opera 10/mac bug, dojo adds <br/>

I did notice the extra <br> (from the www.dojotoolkit.org site, actually), but it only happens on Opera 10/mac.

There's a <br> as the first child of <html> (prior to <head> and <body>).

Doesn't seem to hurt anything though.

comment:3 Changed 10 years ago by webmaser

I just tried it on Linux - Fedora 11, Opera 10.1 -> the same problem:

same at http://download.dojotoolkit.org/releas... url <br> tag behind <html>, when reload page it disappear, when open in new tab, <br> was there again.

comment:4 Changed 10 years ago by webmaser

Tried in new Opera 10.10 / Windows Vista and the <br> tag is always there. So the problem is on every OS. It could have higher priority..

comment:5 Changed 9 years ago by Adam Peller

Owner: changed from anonymous to James Burke
Status: reopenednew
Summary: Opera 10/mac bug, dojo adds <br/>Opera 10: dojo adds <br/>

comment:6 Changed 9 years ago by James Burke

Milestone: tbd1.5

comment:7 Changed 9 years ago by Honza

I can simply reproduce the issue when loading this page: http://www.softwareishard.com/har/viewer/

Using Opera 10.10, build 1893, OS Windows XP (the page uses Dojo 1.3.1)

Honza

comment:8 Changed 9 years ago by James Burke

It was reported in dojo-interest that perhaps this command is causing an issue for Opera 10:

try{
       document.execCommand("BackgroundImageCache", false, true);
}catch(e){
       // sane browsers don't have cache "issues"
}

http://article.gmane.org/gmane.comp.web.dojo.user/42493

It was suggested that this block be protected by an if (dojo.isIE === 6) call. I would like to confirm with someone at Opera about this issue and if this is not something that should just be fixed in Opera. Anyone have a contact?

comment:9 Changed 9 years ago by webmaser

It seams to be fixed in new Opera 10.50

comment:10 Changed 9 years ago by James Burke

Milestone: 1.5tbd
Resolution: wontfix
Status: newclosed

Marking resolved, wontfix since it seems to have been resolved on Opera's side.

comment:11 Changed 9 years ago by palko

Simple fix is to add CSS:

br {
    display: none;
}

body br {
    display: inline;
}

Seems that this does not break anything else.

comment:12 Changed 9 years ago by palko

Previous comment should state workaround, not fix. Sorry for mistake.

Note: See TracTickets for help on using tickets.