Opened 10 years ago

Closed 10 years ago

#10334 closed defect (wontfix)

Tree: focus gets lost entering hidden root node tree (webkit)

Reported by: bill Owned by: bill
Priority: high Milestone: tbd
Component: Dijit Version: 1.4.0b
Keywords: a11y Cc:
Blocked By: Blocking:

Description

Testing Type: Accessibility (Keyboard)

Browser Affected: Chrome 3 & Safari 4

Steps to Reproduce:

  1. Open Safari or Chrome browser
  2. Go to http://archive.dojotoolkit.org/dojo-2009-11-11/dojotoolkit/dijit/tests/test_Tree.html
  3. With your mouse, click on the first root node (Continents)
  4. Press the Tab key twice

Actual Result : Now the focus get lost. If you press enter an alert(Hello world) is shown.

Looks like the focus is getting lost on the hidden root node.

Notes:

  1. works on FF
  2. fails on 1.3 also

Change History (1)

comment:1 Changed 10 years ago by bill

Resolution: wontfix
Status: newclosed

This is a browser bug (it's jumping to a <span tabIndex=-1> inside of a display:none div), and it's fixed in Chrome 4 beta, so I don't think it's worth working around in dojo.

Note: See TracTickets for help on using tickets.