Opened 10 years ago

Closed 10 years ago

#10329 closed defect (fixed)

beginUpdate/endUpdate within a resizable container clears contents

Reported by: Bryan Forbes Owned by: Nathan Toone
Priority: high Milestone: 1.4
Component: DojoX Grid Version: 1.4.0b
Keywords: Cc:
Blocked By: Blocking:

Description

After the grid has initialized, using beginUpdate, adding some items to the store, and then calling endUpdate will cause the grid to clear its contents on every other resize. I have found a work-around by setting grid.scrollTop to 0 before calling the first beginUpdate. The problem is that view.setScrollTop() gets called twice when endUpdate is called. The first time, it sets grid.scrollTop to 0, but the subsequent call sets it back to undefined.

Attachments (1)

test_grid_resize.html (2.5 KB) - added by Bryan Forbes 10 years ago.

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by Bryan Forbes

Attachment: test_grid_resize.html added

comment:1 Changed 10 years ago by Nathan Toone

Resolution: fixed
Status: newclosed

(In [20793]) Fixes #10329 - grid scrolling fixes !strict

Note: See TracTickets for help on using tickets.