Opened 10 years ago

Closed 10 years ago

#10326 closed defect (duplicate)

TabContainer in IE doesn't show scroll buttons

Reported by: mark007 Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.4.0b
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

I have a wide TabContainer? on a page that I notice in 1.4b2, when I use the keyboard zoom controls in browsers, ie CTRL + and CTRL -, all browsers except for IE will begin to show the TabContainer? scroll buttons.

When I zoom in IE, the scroll buttons don't appear so I have to literally scroll accross the page using the scroll bar at the bottom of the window, rather than the lovely new TabContainer? scroll buttons.

Small sample below that should be able to reproduce it. I am not sure if there is anything special about code below that triggers it.

<html>
        <title>Hardware Planning Tool</title>
        <link rel=stylesheet href="dojo1.4b2/dijit/themes/soria/soria.css" type="text/css">
        <link rel=stylesheet href="dojo1.4b2/dojo/resources/dojo.css" type="text/css">
        <body class="soria">
                <div id="mainTabContainer" dojoType="dijit.layout.TabContainer" style="width:100%;height:100%">
                        <div id="new" dojoType="dijit.layout.ContentPane" title="New"></div>
                        <div id="on_hold" dojoType="dijit.layout.ContentPane" title="On Hold"></div>
                        <div id="ordered" dojoType="dijit.layout.ContentPane" title="Ordered"></div>
                        <div id="sourced_internally" dojoType="dijit.layout.ContentPane" title="Sourced Internally"></div>
                        <div id="rejected" dojoType="dijit.layout.ContentPane" title="Rejected"></div>
                        <div id="loaners" dojoType="dijit.layout.ContentPane" title="Loaners"></div>
                        <div id="closed" dojoType="dijit.layout.ContentPane" title="Closed"></div>
                                        </div>
        </body>
        <script type="text/javascript" src="./dojo1.4b2/dojo/dojo.js" djConfig="parseOnLoad: true"></script>
        <script type="text/javascript" src="functions.js"></script>
</html>

Change History (1)

comment:1 Changed 10 years ago by bill

Milestone: 1.4tbd
Resolution: duplicate
Status: newclosed

We just don't support ctrl+/ctrl- on a page because there's no event from the browser telling us that the user changes the font size. I understand that this is a hole in our design.

Dup of #4560.

Note: See TracTickets for help on using tickets.