Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#10322 closed defect (fixed)

ComboBox invalid icon is not persistent after blur

Reported by: Douglas Hays Owned by: Douglas Hays
Priority: high Milestone: 1.4
Component: Dijit - Form Version: 1.4.0b
Keywords: a11y Cc: Becky Gibson
Blocked By: Blocking:

Description

Run dijit/tests/form/test_ComboBox.html and focus the combobox labelled "US State test 4". Focus and tab away. The invalid state should be visible since the field is required but it isn't. Seems to be caused by [20406].

Change History (2)

comment:1 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [20784]) Fixes #10322. Ensure validate() is called from ComboBox::_setBlurValue. Added automated test.

comment:2 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.