Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#10315 closed defect (fixed)

ColorPalette: focus trapped in the color palette test page

Reported by: Becky Gibson Owned by: bill
Priority: high Milestone: 1.4
Component: Dijit Version: 1.4.0b
Keywords: a11y Cc: Douglas Hays
Blocked By: Blocking:

Description (last modified by bill)

Browsers Affected: FireFox? 3.0 FireFox? 3.5 Safari 4.0 Chrome 3.0

Steps to Reproduce:

1.- Open the browser 2.- Go to the Color Picker widget 3.- Press the Tab key to set focus in the first widget. 4.- Continue to navigate using tab. 5.- Attempt to focus any of the browser's functions, using the tab key.

Actual Result : Focus goes from one palette to another, never returning to the browser

window, trapping the user in its content.

Expected Result: To be able to navigate through the browser's menu/adress bar/toolbar/etc after focusing the widget, just as it works in Internet Explorer (6,7,8).

I looked in the test page code and this doesn't appear to be related to anything there. This did not happen in 1.3.2.

Change History (4)

comment:1 Changed 10 years ago by bill

Description: modified (diff)
Milestone: tbd1.4
Owner: set to bill
Status: newassigned

Related to #5119.

comment:2 Changed 10 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [20780]) Big cleanup of ColorPalette code, fixing focus issues and rolling back most of #5119 as it missed the point that we should set tabIndex >= 0 on nodes that we focus. Fixes #10315, refs #5119 !strict.

comment:3 Changed 10 years ago by bill

(In [20782]) More ColorPalette changes:

  • Last time forgot to check in template change.
  • Make mouse-off of ColorPalette clear highlighted node.
  • Don't bother focusing due to mouse hover changes; I don't think it's necessary. Focus upon clicking or tabbing into ColorPalette.

Refs #10315 !strict.

comment:4 Changed 10 years ago by bill

(In [20794]) Fix focus on IE when arrow keys are pressed. Refs #10315 !strict

Note: See TracTickets for help on using tickets.