Opened 10 years ago

Closed 10 years ago

#10314 closed defect (fixed)

TablePlugins: Completely broken. Clicking 'Insert table' squishes editor and hangs browser.

Reported by: Jared Jurkiewicz Owned by: Mike Wilcox
Priority: high Milestone: 1.4
Component: General Version: 1.4.0b
Keywords: Cc:
Blocked By: Blocking:

Description

TablePlugins?: Completely broken. Clicking 'Insert table' squishes editor and hangs browser.

The experimental plugins are now completely nonfunctional in 1.4. Clicking any action that launches a dialog hangs the entire browser. Not sure why and cannot get good debug info.

This can be seen in local extracts of trunk.

Reproduced behavior on both FF 3, IE7, and Gogole Chrome

Change History (5)

comment:1 Changed 10 years ago by Jared Jurkiewicz

As of extract 5 minutes ago, no longer hangs. But ... nothing shows up after clicking the insert table button and if you click in the page, the editor completely vanishes.

comment:2 Changed 10 years ago by Jared Jurkiewicz

Inspecting in firebug shows the editor has moved offscreen (-9999px top).

So ... something is definitely funky in what it is doing.

comment:3 Changed 10 years ago by Jared Jurkiewicz

The problem is that the table plugins are using DropDown? buttons for the dialog generators (insert table, etc), BUT, they are not specifying a dropDown instance on the button. This apparently causes the DropDownButton? in 1.4 to hand the browser! Ugh.

DropDown? buttons are not needed here, simple Button suffices. So, checking in a fix for that issue.

comment:4 Changed 10 years ago by Jared Jurkiewicz

Milestone: tbd1.4

comment:5 Changed 10 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

(In [20768]) Fixing issue with hanging browser. fixes #10314

Note: See TracTickets for help on using tickets.