Opened 13 years ago

Closed 12 years ago

#1031 closed defect (fixed)

Disable selection is inconsistent

Reported by: guest Owned by: bill
Priority: high Milestone: 0.9
Component: HTML Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

It seems "dojo.html.disableSelection" doesn't work properly (or rather how I would expect it to work).

Example: <div id="divA">A<div id="divB">B</div></div>

In IE when I disable selection on "divA" A text becomes unselectable, but B is still selectable. In Mozilla both are unselectable.

I understand Dojo tries to simplify JS development by minimizing the number of instances where it behaves differently in different browsers.

Attachments (1)

selection.patch (643 bytes) - added by Jonathan Bond-Caron 13 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 13 years ago by dylan

Owner: changed from anonymous to Bryan Forbes

comment:2 Changed 13 years ago by dylan

Milestone: 0.40.5

comment:3 Changed 13 years ago by Jonathan Bond-Caron

Here's the fix for IE, if the intended behavior is to disable selection of children nodes as well.

Opera does not support text selection atm

Changed 13 years ago by Jonathan Bond-Caron

Attachment: selection.patch added

comment:4 Changed 12 years ago by Adam Peller

Component: GeneralHTML

code currently lives in dijit._Widget

comment:5 Changed 12 years ago by Adam Peller

Owner: changed from Bryan Forbes to bill

comment:6 Changed 12 years ago by bill

Actually the code is in dojo.setSelectable(), but I guess I can take a look. I remember noticing this problem for TitlePane?'s title bar.

comment:7 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

(In [9954]) Fix setSelectable() on IE to affect the selectability of all the subnodes. This makes IE function like Mozilla. To test this change, just try selecting the label on a tab (TabContainer?.js). Fixes #1031.

Note: See TracTickets for help on using tickets.