Opened 10 years ago

Closed 10 years ago

#10300 closed defect (fixed)

[regression] ComboBox inheritance not working

Reported by: Douglas Hays Owned by: Eugene Lazutkin
Priority: high Milestone: 1.4
Component: Core Version: 1.4.0b
Keywords: Cc: Eugene Lazutkin, James Burke
Blocked By: Blocking:

Description

Beginning with [20738], ComboBox? is not working correctly. If you down arrow until More Choices and then TAB away, then the box value remains More choices instead of being reset to the last value. To recreate:
1) load dijit/tests/form/_autoComplete.html?testWidget=dijit.form.ComboBox?
2) find the box labeled "With option tags, autoComplete=true, pageSize=30, and a descending sort"
3) focus and down arrow until More choices is selected
4) press TAB
The value should revert to California but it stays More choices.
ComboBox? calls dijit.form.ValidationTextBox?.prototype._setValueAttr
which calls this.inherited(arguments) which no longer calls TextBox:_setValueAttr even though ValidationTextBox? inherits from TextBox?. This works fine in 1.3.2. Assigning to bill since I don't know if ComboBox? is doing inheritance incorrectly or if the new core changes to dojo.declare are broken.

Change History (3)

comment:1 Changed 10 years ago by bill

Component: DijitCore
Owner: changed from bill to Eugene Lazutkin

Yes, I noted another breakage in #9862, I'm assuming it's a dojo.declare problem.

comment:2 Changed 10 years ago by Eugene Lazutkin

Related to #9862.

comment:3 Changed 10 years ago by Eugene Lazutkin

Resolution: fixed
Status: newclosed

(In [20755]) dojo.declare: regression cleanup, !strict, fixes #10300, refs #9862.

Note: See TracTickets for help on using tickets.