Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#10295 closed defect (fixed)

Dojox File uploader - Remove file issue (Gana)

Reported by: ganapathyp Owned by: Mike Wilcox
Priority: high Milestone: 1.4
Component: DojoX Form Version: 1.3.2
Keywords: Gana File uploader Cc:
Blocked By: Blocking:

Description

Removing file though removes the <TD> tag in html, when i click on submit, it still uploads the file i just removed... Easy to recreate: Scenario 1:

  1. Add 3 files
  2. Remove 1st file
  3. Add a new file
  4. Click on submit/upload... even file removed is uploaded

Scenario 2:

  1. Upload 1st time
  2. Add 3 files
  3. Remove 1st file and try again

var h = new dojox.form.FileUploader?(dojo.mixin({

force:"html", showProgress:true, progressWidgetId:"progressBarHtml", selectMultipleFiles:true, fileListId:"hFiles", tabIndex:11

}, props), "btnH");

Change History (5)

comment:1 Changed 10 years ago by ganapathyp

I'm sorry, clicked on it while i was still composing... Defect is easily reproducable... Remove files has issues after you upload it once 1.Upload once

  1. Add 3 files
  2. Remove 1st file
  3. click on upload ...

Uploader will add all 3 files...

comment:2 Changed 10 years ago by Adam Peller

Owner: changed from dante to Mike Wilcox

comment:3 Changed 10 years ago by Mike Wilcox

You are right. The problem was the names of fileInputs needed to stay in numeric order and start with zero - at least for my PHP code in resources. So this problem actually occurs with the first upload if you delete any of the files but the last. The fix will be committed.

comment:4 Changed 10 years ago by Mike Wilcox

Resolution: fixed
Status: newclosed

(In [20771]) Fixes #10264, #10271, #10313, #10235, #10295 - works in Dialog boxes (still not tabs, that one is harder) - fixed HTML uploader issues. Added new properties to prevent errors of large uploads. Added ability for individual file errors (in Flash).

comment:5 Changed 10 years ago by Mike Wilcox

Milestone: tbd1.4
Note: See TracTickets for help on using tickets.