Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#10259 closed defect (fixed)

Firefox 3.6 - error when loading firebug.js

Reported by: Les Owned by: Mike Wilcox
Priority: low Milestone: 1.4
Component: General Version: 1.4.0b
Keywords: Firebug Cc: dante, James Burke
Blocked By: Blocking:

Description

I'm not able to open many Dojo test applications using Firefox 3.6 when Firebug 1.5b1 is enabled. This works fine in FF 3.5.4.

Steps to reproduce:
1.) Enable Firebug.
2.) Go here: http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/test_Tree.html

You will see an error in FB's console:

failed loading ../../dojo/./_firebug/firebug.js with error: TypeError: setting a property that has only a getter

The assignment below on line line 158 (firebug.js) causes an error "TypeError?: setting a property that has only a getter"

window.console = {...

Attachments (1)

pic.PNG (97.9 KB) - added by Les 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by dante

Owner: changed from anonymous to Mike Wilcox

comment:2 Changed 10 years ago by Mike Wilcox

Cc: dante James Burke added

I don't have 3.6 installed at the moment. But I suspect this is not an issue with firebug lite, I think it's dojo not detecting the 3.6 browser properly. dojo.isFF should prevent that line from executing that is throwing the error.

comment:3 Changed 10 years ago by James Burke

Resolution: worksforme
Status: newclosed

I just tried the link above using Firefox 3.6b1 on OS X using Firebug 1.5X.0b3 and it worked for me, no errors.

comment:4 Changed 10 years ago by Les

Resolution: worksforme
Status: closedreopened

This happens on Windows. I tried it on two different PCs using XP (FB 1.5b1 and b3)

Download FF 3.6b2pre here: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-1.9.2/

Changed 10 years ago by Les

Attachment: pic.PNG added

comment:5 Changed 10 years ago by bill

This reproduces for me ( on FF3.6/firebug 1.4.5/WinXP) but it looks it's just because dojo.isFF isn't defined, since this is a pre-release of firefox.

We could change the dojo.isFF reference in firebug.js to dojo.isMoz; that fixes it for me.

comment:6 Changed 10 years ago by James Burke

Resolution: fixed
Status: reopenedclosed

(In [20737]) Fixes #10259, FF 3.6preb2 reports itself as Namoroka and not Firefox, but do not want to build in extra logic to isFF since we just got rid of needing it except for backwards versions, so fixing firebug.js by making sure it does not try to do the console work if firebug's console is defined (known via console.firebug) \!strict

comment:7 Changed 10 years ago by bill

Milestone: tbd1.4
Note: See TracTickets for help on using tickets.