Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#10247 closed defect (fixed)

regression: autocomplete in ComboBox not working correctly

Reported by: Douglas Hays Owned by: Douglas Hays
Priority: high Milestone: 1.4
Component: Dijit - Form Version: 1.4.0b
Keywords: Cc:
Blocked By: Blocking:

Description

load dijit/tests/form/test_ComboBox.html
Focus the 2nd ComboBox? and press down arrow to popup the list.
Press the down arrow several times to cycle thru the popup menu and longer items are only partially highlighted.
This worked in 1.3.

Change History (3)

comment:1 Changed 10 years ago by Douglas Hays

Seems to be caused by [20406]

comment:2 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [20711) Fixes #10247. References #6022, #9914. Highlight autocompleted text based on search criteria length and not current caret position (that is subject to change).

comment:3 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.