Opened 9 years ago

Closed 9 years ago

#10239 closed defect (invalid)

[regression] Alternative text is not present for an image map area.

Reported by: reamsc Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.3.0
Keywords: Cc: Becky Gibson
Blocked By: Blocking:

Description

I had to supply alt="" in the following files.

dojoroot\dijit\layout\TabController?.js And dojoroot\dijit\layout\templates\_TabButton.html

Change History (5)

comment:1 Changed 9 years ago by Adam Peller

Cc: Becky Gibson added

comment:2 Changed 9 years ago by Becky Gibson

Ths is written against 1.3. The issue with _TabButton.html (missing alt="" on the blank.gif image used as a spacer) has been addressed for 1.4. That spacer gif is no longer used.

Can you please be more specific about what the issue was in TabController?.js? When I look at the 1.3 TabController? in Firebug I don't see any img's missing alt text except for the one defined in _TabButton.html.

comment:3 Changed 9 years ago by bill

Milestone: tbd1.4
Owner: set to bill
Status: newassigned
Summary: Alternative text is not present for an image map area.[regression] Alternative text is not present for an image map area.

Thanks for the detailed description / test case.

Looks like a regression starting with the scrolling tab container rewrite, although the actual bug is in the pre-rewrite old code. StackContainer.removeChild() calls layout() before a new tab has been selected, which calls tablist.resize() --> _getScrollForSelectedTab(), which references the recently destroyed this._selectedTab.

comment:4 Changed 9 years ago by bill

Milestone: 1.4tbd
Owner: bill deleted
Status: assignednew

Ugh, that above comment was for #10246, I typed into the wrong ticket.

(As for this ticket, will close as invalid unless we get more details.)

comment:5 Changed 9 years ago by bill

Resolution: invalid
Status: newclosed

Closing for lack of response.

Note: See TracTickets for help on using tickets.