Opened 10 years ago

Closed 10 years ago

#10236 closed enhancement (wontfix)

dojo.data.api.Read.hasAttribute should be changed to hasAttributeValue or hasValue

Reported by: youngho Owned by: Jared Jurkiewicz
Priority: low Milestone: tbd
Component: Data Version: 1.4.0b
Keywords: dojo.data hasAttribute Cc:
Blocked By: Blocking:

Description

dojo.data.api.Read.hasAttribute document describe as 'Returns true if the given *item* has a value for the given *attribute*.

But the name 'hasAttribute' can be easily misleading like 'Returns true if the given *item* has a given *attribute*'

Therefore the name should be change to hasAttributeValue or hasValue.

Change History (2)

comment:1 Changed 10 years ago by bill

Component: CoreData
Owner: changed from anonymous to Jared Jurkiewicz

I don't understand, are you talking about an edge case where an item has an attribute with an undefined value, like in the JS world something like {foo: undefined} ?

comment:2 Changed 10 years ago by Jared Jurkiewicz

Resolution: wontfix
Status: newclosed

The name stands. API changes would break existing users. Will not alter.

Note: See TracTickets for help on using tickets.