Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#10234 closed defect (invalid)

Enhanced Datagrid Globalization - Problems loading no english characters

Reported by: Roberto Mosqueda Owned by: evan
Priority: high Milestone: tbd
Component: DojoX Grid Version: 1.4.0b
Keywords: EnhancedDatagrid g11y Cc: David Schwartz, tmayeur@…, Nathan Toone, hwcdl@…, apeller@…, pilar@…
Blocked By: Blocking:

Description

Testing Type: Globalization

Browsers Affected: IE 6,7, and 8, Firefox 3.0 and 3.5, Safari 4 and Chrome 3.

Problem Description: when you use chinese, german, japanese, etc, characters, these characters are not loaded on the enhanced data grid.

Steps to Reproduce:

1.- Open the browser
2.- Create a csv file using german or other language, no english,(verify the csv file is created using UTF-8), see german.csv file to see the data used for the test.
3.- Go to /test_enhanced_grid.html

Actual Result : All data with german characters are not displayed, see image1.gif, only the columns with no special characters are displayed

Expected Result: All data should be displayed no matter the language of the characters.

Attachments (2)

german.csv (865 bytes) - added by Roberto Mosqueda 9 years ago.
image1.gif (24.5 KB) - added by Roberto Mosqueda 9 years ago.

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by Roberto Mosqueda

Attachment: german.csv added

Changed 9 years ago by Roberto Mosqueda

Attachment: image1.gif added

comment:1 Changed 9 years ago by Nathan Toone

Keywords: EnhancedDatagrid added; datagrid removed
Owner: changed from Nathan Toone to Evan

comment:2 Changed 9 years ago by David Schwartz

The EDG has been confirmed to have no problems with non-English characters. Please close.

comment:3 Changed 9 years ago by Nathan Toone

Resolution: fixed
Status: newclosed

comment:4 Changed 9 years ago by Adam Peller

Resolution: fixed
Status: closedreopened

comment:5 Changed 9 years ago by Adam Peller

Resolution: invalid
Status: reopenedclosed

comment:6 Changed 9 years ago by Marcus Reimann

The problem seems to be with the encoding of the file dojox/grid/tests/enhanced/test_enhanced_grid.html. The encoding has to be changed to UTF-8 and then it's possible to use german Umlauts. So, it's important to set both files to the same encoding: CSV file and also HTML/JavaScript file - otherwise the JavaScript? is searching for a column with a wrong name and isn't able to find the appropriate data within the CSV file.

Regards,

Marcus

comment:7 Changed 8 years ago by bill

Owner: changed from Evan to evan
Note: See TracTickets for help on using tickets.